Just for your information, there is a critical patch for ESX to download here. Good news, you don’t need to restart your ESX server.

This is a  critical patch, so you should run it, after testing, as soon as possible in your infrastructure, as this patch is critical.

You can have a look here.

A critical vulnerability in the virtual machine display function might allow a guest operating system to run code on the host. The Common Vulnerabilities and Exposures Project (cve.mitre.org) has assigned the name CVE-2009-1244 to this issue.

Host Reboot Required - No
Virtual Machine Migration or Shutdown Required- Yes

If you are not using Update Manager, you can still download the most recent patch bundle from http://www.vmware.com/download/vi/vi3_patches_35.html and install the bundle using esxupdate from the command line of the host.

http://www.vladan.fr/critical-patch-for-esx-download-now/