Purpose

This article provides steps to upgrade vCenter Server Appliance from 5.0.x/5.1 to 5.5.

Resolution

Notes:
  • vCenter Server Appliance 5.0.1, 5.1.x, and 5.5 use PostgreSQL for the embedded database, instead of IBM DB2 that was used in vCenter Server Appliance 5.0. If you use the embedded database with the vCenter Server Appliance, when you upgrade to version 5.5, the embedded IBM DB2 database is migrated to a PostgreSQL database. The configuration state of your existing database is preserved and the schema is upgraded to be compatible with vCenter Server Appliance 5.5.
  • vCenter Server Appliance 5.5 embedded vPostgres database can now support as many as 100 vSphere ESXi hosts and 3,000 virtual machines.

--> Please see the rest on the VMware KB site : http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2058441